LightOJ1370 (Bi-shoe and Phi-shoe)[欧拉函数]

·· / ·– ·· ·-·· ·-·· / ·–· · ·-· ··· ·· ··· - / ··- -· - ·· ·-·· / ·· / ·– ·· -·
题目链接:https://vjudge.net/problem/27078/origin

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo’s length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1

Sample Output

Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha

这题是欧拉函数,先生成phi表,然后暴力枚举,注意phi表是不单调的,所以枚举的时候需要把输入排个序。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
const int N=1100009;
int phi[N];
int a[N];
void phi_table(int n,int *phi) {
for (int i=2;i<=n;i++) phi[i]=0;
phi[1]=1;
for (int i=2;i<=n;i++) if (!phi[i])
for (int j=i;j<=n;j+=i) {
if (!phi[j]) phi[j]=j;
phi[j]=phi[j]/i*(i-1);
}
}
int main() {
int T,n;
long long ans=0;
phi_table(N-1,phi);
//phi[1]=0;
scanf("%d",&T);
for (int z=1;z<=T;z++) {
ans=0;
scanf("%d",&n);
for (int i=0;i<n;i++) scanf("%d",&a[i]);
std::sort(a,a+n);
for (int i=0,j=2;i<n;) {
if (phi[j]>=a[i]) {
ans+=j;
i++;
}
else j++;
}
printf("Case %d: %lld Xukha\n",z,ans);
}
}